Hello World

Welcome to Hexo! This is your very first post. Check documentation for more info. If you get any problems when using Hexo, you can find the answer in troubleshooting or you can ask me on GitHub.

Quick Start

Create a new post

1
$ hexo new "My New Post"

More info: Writing

Run server

1
$ hexo server

More info: Server

Generate static files

1
$ hexo generate

More info: Generating

Deploy to remote sites

1
$ hexo deploy

More info: Deployment

Share Comments

암살교실

지구를 멸망시키려는 정체불명의 초생명체가 학급의 담임교사가 되고, 학생들은 그를 암살하는 훈련을 받는다.

원작이 만화라고는 하지만 너무 병맛이다 ㅋ

오글오글거리면서 끝까지 봤다 ㅋㅋ

Share Comments

베테랑

열혈 베테랑 형사와 악한 재벌 2세의 대결을 그린 영화이다.

배우 황정민과 유아인 뿐만 아니라 비중있는 조연 배우들의 캐릭터가 돋보였다.

근래 본 영화들 중에 가장 쫄깃쫄깃한 액션을 보여줬다.

Share Comments

Reverse Array Recursively

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
#include <iostream>
using namespace std;
void reverse(int *A, int N, int i, int j)
{
// base case
if(i >= j) return;
// swap
int t = A[i];
A[i] = A[j];
A[j] = t;
// recursive
reverse(A, N, ++i, --j);
}
void reverse(int *A, int N)
{
reverse(A, N, 0, N-1);
}
int main() {
// your code goes here
int A[5] = {1, 2, 3, 4, 5};
reverse(A, 5);
for(int i = 0; i < 5; i++) {
cout << A[i] << ",";
}
cout << endl;
return 0;
}
Share Comments

Back to High School Physics

A particle has initial velocity and constant acceleration. If its velocity after certain time is v then what will its displacement be in twice of that time?

Input

The input will contain two integers in each line. Each line makes one set of input. These two integers denote the value of v (-100 <= v <= 100) and t(0<=t<= 200) ( t means at the time the particle gains that velocity)

Output

For each line of input print a single integer in one line denoting the displacement in double of that time.

Sample Input

0 0
5 12

Sample Output

0
120

Source Code

1
2
3
4
5
6
7
8
9
int main(int argc, char** argv)
{
int v, t;
while(cin >> v)
{
cin >> t;
cout << v * t * 2 << endl;
}
}

Reference

http://uva.onlinejudge.org/external/100/10071.html

Share Comments

연속 부분 최대곱

문제

문제

소스 코드

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
public class MAX{
public static double[] nums = {1.1, 0.7, 1.3, 0.9, 1.4, 0.8, 0.7, 1.4};
public static void main(String[] args){
float max = 1;
for(int i = 0; i < nums.length; i++){
if(nums[i] > 1){
float m = 1;
for(int j = 0; j < nums.length - i; j++){
m *= nums[i + j];
if(max < m){
max = m;
}
}
}
}
System.out.println(max);
}
}
Share Comments

홈 (2015)

외계인의 침공으로 엄마와 이별하게 된 주인공이 외계인과 함께 엄마를 찾아 떠난다는 이야기이다.

드림웍스의 작품답게 중간중간 재미난 요소들이 많이 나온다.

가슴 뭉클한 감동을 주는 영화이다.

Share Comments

후위 표현식

중위 표현식을 후위 표현식으로 변경하라.

1
ex) 5 + (4 - 2) - 3 * 2 === 5 4 2 - + 3 2 * -

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
import java.util.*;
public class Postfix{
public static void main(String[] args){
String expression = "5+(4-2)-3*2";
Stack stack = new Stack();
StringBuilder sb = new StringBuilder();
for(int i = 0; i < expression.length(); i++){
char c = expression.charAt(i);
switch(c){
case '0':
case '1':
case '2':
case '3':
case '4':
case '5':
case '6':
case '7':
case '8':
case '9':
sb.append(c);
break;
case '+':
case '-':
case '*':
case '/':
if(!stack.empty() && (stack.peek() != '(')){
if(order(stack.peek()) <= order(c)){
sb.append(stack.pop());
}
}
stack.push(c);
break;
case '(':
stack.push(c);
break;
case ')':
char op;
while((op = stack.pop()) != '('){
sb.append(op);
}
break;
default:
System.out.println("Error");
return;
}
}
while(!stack.empty()){
sb.append(stack.pop());
}
System.out.println(sb.toString());
}
public static int order(char op){
switch(op){
case '*': case '/': return 1;
case '+': case '-': return 2;
default: return 0; }
}
}
}
Share Comments

1과 2의 합

어떤 정수 n이 있다. 이 정수를 1과 2의 합의 순서로 표현할 때 나타낼 수 있는 방법의 수를 구하시오. 예를 들어 n=3 이면
3 = 1 + 1 + 1
= 1 + 2
= 2 + 1
단, 1 + 2 와 2 + 1은 그 operand는 같지만 순서가 다르므로 다른것으로 친다.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
public class Sum{
public static void main(String[] args){
System.out.println(fibonacci(5));
}
public static int fibonacci(int num){
if(num == 1){
return 1;
}
if(num == 2){
return 2;
}
return fibonacci(num - 2) + fibonacci(num - 1);
}
}
Share Comments

바이러스

바이러스가 1마리 있다. 이 바이러스의 수는 1초 후에 2배로 불어날 수도 있고 1/3(소숫점 이하 버림)로 줄 수도 있다. 현재 몇 마리의 바이러스가 존재하는지 주어질 때 1마리의 바이러스에서부터 최소 몇 초의 시간이 흘러 현재 상태가 되었는지 구하시오.

ex) 현재 바이러스가 7마리 있다면,
1 -> 2 -> 4 -> 8 -> 16 -> 32 -> 64 -> 21 -> 7
이보다 더 빠른 시간 안에 7마리가 될 수는 없다.
따라서 답은 8초이다.

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
import java.util.*;
public class Virus{
public static void main(String[] args){
int num = 7;
Queue queue = new LinkedList();
queue.add(new Element(1, 0));
while(true){
Element e = queue.remove();
if(e.getNum() == num){
System.out.println(e.getTime());
return;
}
queue.add(new Element(e.getNum() * 2, e.getTime() + 1));
queue.add(new Element(e.getNum() / 3, e.getTime() + 1));
}
}
class Element{
private int num;
private int time;
public Element(int num, int time){
this.num = num;
this.time = time;
}
public int getNum(){
return num;
}
public int getTime(){
return time;
}
}
}
Share Comments